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trademark of the European 

Community. 
 

 The C-Tick mark is a registered 
trademark of the Australian Spectrum 
Management Agency. 

 

The CSA mark is a registered 
trademark of the CSA 
International. 

 

This symbol indicates 
product compliance with 

the Canadian Interference-Causing 
Equipment Standard (ICES-001). It also 
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the user documentation in all cases where the 
symbol is marked on the instrument.  
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This symbol on the front panel power 
button is illuminated amber if the 

instrument is in STANDBY power mode, green 
if the power button is turned on, or OFF (not 
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Section 1: MIMO Introduction 
 

 

Preface 
This Agilent Technologies Inc. multiple-in multiple-out (MIMO) Application Guide introduces you to the concepts of 
MIMO technology with the associated topics: OFDMA, WLAN, and WiMAX.  

It also describes how you can configure your Agilent Technologies Inc. software and instrumentation for a complete 
measurement solution.  

• Agilent V2820A VSA 
• Agilent V2920A VSG 
• Agilent V2895A MIMO Synchronization Unit 
• Agilent V2901A SignalMeister RF Communications Test Toolkit 

 

SISO to MIMO 
 

Commercial radio technology has reached a turning point where the move is from single carrier technologies 
(single-input single-output, SISO) where one digital symbol is transmitted at a time, to a new paradigm, where 
potentially hundreds of symbols are transmitting simultaneously (multiple-input multiple-output, MIMO). The change 
has been driven by customer demand for more mobile services, and the decreasing cost of the digital signal 
processing technology required to deploy high-bandwidth broadband wireless systems. The technology can now be 
used in a variety of commercial communications devices. For example, phones, PDAs, and the laptops upon which 
we have become so dependent. 

The technology of choice for this broadband connection is based on a modulation scheme called orthogonal 
frequency division multiplexing (OFDM). OFDM has very good spectral efficiency and is quite tolerant of the ever-
present interference in the bands where it is used. One of the key reasons for this is that it transmits hundreds of 
symbols simultaneously, yet at a low rate per symbol. 
 



Section 1: MIMO Introduction 

SISO: Single-Input Single-Output 
The figure below shows a typical SISO radio with one transmitter and one receiver with information sent over a 
single data channel. This configuration is used in almost all radio products today. While there may be an extra 
antenna for spatial diversity (constantly switched for the best signal path), there is a single upconverter and a single 
downconverter, a single demodulator/modulator in the radio, and a single data stream in the higher levels of the 
product's communications stack. 

 
 

Multi-Path 
Multi-path architecture adds complexity to the SISO transmission. The figure below shows a Bluetooth signal with a 
symbol rate of 1M symbols per second. That means that the receiver will expect a specific symbol within a period of 
one microsecond. If the multi-path architecture delays the signal by more than one microsecond, the receiver will 
receive the symbol in the next symbol period, causing a significant symbol error. 

 
If the difference in path length between direct and reflected paths exceeds 1 ms, the receiver will receive the 
symbol in the next symbol period. 
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MIMO: Multiple-Input Multiple-Output 
MIMO is the most significant change to radio architecture in radio history. The principle is simple: If you have one 
transmitter, you can transmit some data from point A to point B; If you have four transmitters (or four carriers) the 
data is four times more likely to get to its destination, but the transmission would take up four times as much 
bandwidth. MIMO aligns those four independently modulated OFDM carriers on top of each other resulting in four 
separate transmissions, sharing a single frequency. It can carry up to 3.5 times as much information in the same 
bandwidth as a single carrier (see the figure below). The most complex part of this operation is getting the 
transmission back to four independent radio signals at the receiver. The principle is not new, but the cost of the 
technology has decreased such that it is now commercially viable. 

 
By using somewhere between two and four carriers to transmit the data, and having two and four receivers, the 
likelihood of receiving everything is much better, so the spectral efficiency rises dramatically, although that 
efficiency comes with a higher level of complexity. 
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MIMO Radio Configuration 
The figure below shows some typical MIMO configurations. A 2×2 system contains two transmitters and two 
receivers; A 4×4 system has four transmitters and four receivers. Many commercial WLAN devices today employ a 
3×2 configuration of three transmitters and two receivers. 

 

Multiple paths degrade the signal quality on SISO systems, but 
are necessary for MIMO systems. If there are two unknown 
transmitted signals and two measurements at the receivers, and 
the two measurements are sufficiently independent, it is possible 
to identify the transmitted symbols. For example, if a MIMO 
transmitter transmits two signals on the same frequency, each 
signal takes a slightly different path to the receiver and each 
signal's characteristics diverge from the originally transmitted 
signals (mainly due to multi-path distortion). Both receivers 
receive a mixture of both the original signals. As the two 
receivers are independent, you can use simultaneous equations 
on the two received signals and identify the transmitted symbols. 

 

 

 

 
 

Spectral Efficiency: SISO versus MIMO 
MIMO allows the same bandwidth to be used multiple times, allowing a higher spectral efficiency. You can see that 
when you compare the efficiency of 802.11a/g wireless LAN signals without MIMO to the 802.11n wireless LAN 
signals with MIMO. 

 

 Agilent V2895A MIMO Synchronization Unit 
10 MIMO Application Guide 



Section 1: MIMO Introduction 

Hardware 
To transmit multiple signals you must synchronize the phase and sampling alignment on multiple channels. This 
can easily be achieved by using two Agilent V2920A Vector Signal Generators (VSGs) with the Agilent V2895A 
MIMO Synchronization Unit. Conversely, to independently receive MIMO signals, it is necessary to synchronize two 
Agilent V2820A Vector Signal Analyzers (VSAs). In such a test setup, all V2820As and V2920As are identical 
standard units. The system also provides the flexibility to use V2920A VSGs as standalone generators. 

When configured as a system, all the analyzers share common local oscillator and clock signals. The master 
provides the LO, a 100 MHz digital clock and trigger synchronization to the MIMO Synchronization Unit. The latter 
unit distributes those signals to all the other units. Signal sampling should be aligned within ±1 ns. 

The Agilent second generation MIMO systems are: 

• Precise and stable relative to carrier phase 
o Up to ±60 degrees fixed phase offset. This varies with the instrument configuration. 
o <1 degree peak-peak relative phase jitter 

• Precise and stable ARB alignment 
o Up to ±1 ns fixed time offset 
o <1 ns peak-peak jitter between the ARB waveforms 

• ~60 ns burst rise and fall times (10% to 90%) 
• <-90 dBc on-off power ratio between bursts 

 

 
The figure above shows three MIMO measurements on a two-channel system. The upper measurement is an error 
vector magnitude (EVM) measurement across the OFDM subcarriers on each channel (shown by the yellow and 
red plots). Underneath that you can see the channel frequency response over 60 subcarriers. Finally, you see the 
constellation of a channel. 
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These scope screen shots show that the modulation from all of the RF sources is closely synchronized. 

 

The Long-Term Evolution (LTE) of Wireless 
The Long Term Evolution of wireless (LTE), also known as Ultra Mobile Broadband (UMB) for cellular devices (see 
the figure below), is the migration from 3G technology to 4G technology. Fourth generation technology of radios, 
cellular phones, cellular data devices, or cellular terminals will be based on OFDM technology and MIMO radio 
configurations. Right now the commercial application is wireless LAN, which has moved to 4G. When choosing test 
equipment for testing today's radio standards, it is important to consider the evolution of wireless technology and to 
ensure that your purchases are forward compatible. 
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Orthogonal Frequency Division Multiplexing (OFDM) 
Orthogonal frequency division multiplexing (OFDM) is a form of digital modulation used in a wide array of 
communications systems. The following topic will explain what OFDM is, why it is important, where it is used, and 
what test instrumentation is required to maintain it. 

• OFDM is spectrally efficient, carrying more data per unit of bandwidth than such services as GSM and W-
CDMA. The figure below shows a comparison of the spectral efficiency of the leading cellular technologies and 
how they compare to WLAN and WiMAX. Fourth Generation technology, often referred to as the Long Term 
Evolution of wireless (LTE) and Ultra Mobile Broadband (UMB) for cellular devices, plans to use OFDM or 
OFDMA. 

 
• OFDM tolerates environments with high RF interference. Some services that use OFDM, such as WLAN, 

operate in the unregulated Industrial Scientific Medical (ISM) bands, where they must coexist with many 
unregulated devices, including analog cordless phones (900 MHz), microwave ovens (2.45 GHz), Bluetooth 
devices (2.45 GHz), digital cordless phones (2.45 GHz or 5.8 GHz) and Wireless LAN (2.45 GHz or 5.8 GHz). 

 

 

Digital Modulation Overview 
Most forms of digital transmission involve modulating a pair of summed sine waves that differ in phase by 90°. The 
modulation signal can be represented by the vector sum of the in-phase (I) and quadrature (Q) components, as 
shown in the figure below. 
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There are many ways to encode digital information. If you change the phase relationships between the two sine 
waves, the result is called phase shift keying (PSK). A common type of PSK is quadrature phase shift keying 
(QPSK), which uses four phases; if eight phases are used, the result is 8PSK. 

If you vary both the amplitude and phase of the two sine waves, the result is quadrature amplitude modulation (QAM). 

The best way to analyze the resulting signals is with a vector signal analyzer (VSA), for example, the Agilent 
V2820A, which processes all of its data as quadrature pairs in a constellation diagram. The figure below shows 
constellation diagrams for three types of modulations: QPSK, 8PSK, and 16QAM. 

Input Signal Analyzer Display 

 
 

Modulation Quality Analysis 
A good measurement of the quality of a received digital signal is error vector magnitude (EVM). This is the ratio of 
the received signal's amplitude and phase compared to its ideal amplitude and phase. Mathematically, EVM is 
determined by: 

 
Cellular technology specifications are usually stated in percent, while the Wireless LAN industry tends to specify 
EVM using decibels. The measurement analysis is depicted in the following illustration: 
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The OFDM Radio 
Many conventional instruments lack the signal processing capability to perform MIMO measurements quickly. As 
shown in the figure below, Agilent Technologies’ DSP enhanced architecture makes it possible to perform the 
analysis very quickly. 

 
This block diagram shows the digital circuit in the V2820A Vector Signal Analyzer and the V2920A Vector Signal 
Generator.  

OFDM is simple in concept, even though its implementation is complex. Mathematically, it can be implemented by 
using an Inverse fast Fourier transform (IFFT) in the transmitter and conversely an FFT in the receiver. The figure 
below shows the parallel symbols being converted to the two modulated sine waves in the output, as if the IFFT is a 
specialized multiplexer. 
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In order to keep things synchronized, an OFDM signal includes several subcarriers (see the figure below) 
designated as pilot carriers. The pilot carriers are used as reference for phase and amplitude for synchronizing the 
receiver as it demodulates the data in the other subcarriers. 

 
 

Key Measurements: Constellation and EVM 
The figure below shows the constellation of a WLAN signal conforming to the 802.11j standard. Note that even 
though the signal has been transmitted using many carriers, it is still essentially a QAM signal. There are also two 
extra symbols, representing the information modulated on the pilot carriers. 

 
OFDM is very pervasive, as shown in Table 1. 
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Table 1: Communication services using OFDM  

Wireless Wireline 

IEEE 802.11a, g, n (WiFi) Wireless LANs ADSL and VDSL broadband access 
via POTS copper wiring 

IEEE 802.15.3a Ultra Wideband (UWB) Wireless PAN MoCA (Multi-media over Coax 
Alliance) home networking 

IEEE 802.16d, e (WiMAX), WiBro, and HiperMAN Wireless MANs 

IEEE 802.20 Mobile Broadband Wireless Access (MBWA) 

DVB (Digital Video Broadcast) terrestrial TV systems: DVB-T, DVB-H, 
T-DMB, and ISDB-T 

DAB (Digital Audio Broadcast) systems: EUREKA 147, Digital Radio 
Mondiale, HD Radio, T-DMB, and ISDB-TSB 

Flash OFDM cellular systems 

3GPP UMTS and 3GPP@ LTE (Long Term Evolution) and 4G 

PLC (Power Line Communication) 

 

WLAN 
WLAN is defined by the IEEE 802.11 standard, of which there are several variations, a through g, as shown in 
Table 2 below. Within a 16.25 MHz bandwidth are 52 carriers, numbered -26 to +26, and spaced 312.5 kHz apart. 
Carriers 7 and 21 (-21, -7, +7 and +21) are the pilots. The packet structure is Preamble - Header - Data Block, and 
the subcarrier modulation types are BPSK, QPSK, 16-QAM, or 64-QAM. 

 
Each carrier within the modulation scheme is referred to as a subcarrier. The subcarriers are spaced at regular 
intervals called the subcarrier frequency spacing (ΔF). The subcarrier frequency relative to the center frequency is 
kΔF, where k is the subcarrier number. 
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Table 2: WLAN Summary 

802.11 Description 

a 54 Mbps OFDM, 5.9 GHz Band, 20 MHz channels 

b 11 Mbps CCK, 2.4 GHz (Legacy, not OFDM) 

g 54 Mbps, 2.4GHz  

j Japanese version of g that uses half the sample rate 

n 

• Not finished yet, expected to finalize in November 2009 
• Like g, but up to 600 Mbps 
• OFDM 
• MIMO 
• 20 and 40 MHz channels 

The original WLAN standard is 802.11b, which is not based on OFDM. "a" and "g" are basically the same: "a" works 
in the 5 GHz ISM band and "g" works in the 2.4 GHz ISM band. "j" is a slower symbol rate version of "g" for the 
Japanese market, and "n" is based on MIMO technology. 

Several organizations are involved with WLAN: WiFi is an industry consortium that defines a required subset of 
802.11 to ensure better operation between different vendors' equipment, while EWC is an industry consortium that 
took the unfinished "n" standard, agreed upon a version, and is attempting to field solutions prior to 802.11N 
ratification. 

Test Equipment Requirements for WLAN 

Test equipment for WLAN must have a frequency range up to 6 GHz and be able to modulate or demodulate 
OFDM signals with a bandwidth of up to 16.25 MHz for all types except for 802.11n, which has a maximum 
bandwidth of 40 MHz. 

WiMAX 
The Worldwide Interoperability for Microwave Access (WiMAX) is very similar in concept to 802.11, but the 
demands of multiple simultaneous users make the implementation much more complex. 

There are two major variations of WiMAX: fixed and mobile. The mobile version, 802.16e-2005 (often called 
802.16e), facilitates the link between mobile devices. It uses Scalable OFDM Multiple Access (SOFDMA), which 
interoperates with OFDMA but requires new equipment. 802.16e also adds MIMO. 

The fixed version of WiMAX, 802.16-2004 (often called 802.16d), uses OFDMA and operates from 2 GHz to 11 
GHz (there is no regulatory approval above 5.9 GHz); it delivers a practical data rate of 10 Mbps over 2 km. 

The differences are summarized in Table 3.  

Table 3: Fixed and Mobile WiMAX 

802.16 Description 

Fielded system for fixed-point access (to the home or office) 802.16-2004  
(also know as 
802.16d) OFDMA (OFDM multiple access) 

2–11 GHz (no regulatory approval above 5.9 GHz) Practical rate: 10 Mbps over  
2 km 

The current version of the standard, upgraded to include mobile wireless 802.16e-2005 

SOFDMA interoperates with OFDMA, but requires new equipment. It Adds MIMOs 
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Fixed WiMAX is similar in some respects to WLAN, that is, it has an OFDM physical layer. Mobile WiMAX is based 
on an OFDMA physical layer. It uses both frequency division multiplex and time division multiplex. Groups of 
subcarriers (see figure below) represent individual data streams. Each group of subcarriers also has a frame 
structure. 

 
Time division characteristics are shown in the figure below. The frame structure equates to a packet. There is a 
timing gap between the uplink and downlink called the transition gap. 

 
Mobile WiMAX is a dynamic system. The amount of data transferred is a function of the modulation type and 
symbol rate on each set of subcarriers. If the link quality is good, a high throughput modulation type such as QAM 
is used, and most of the bandwidth is consumed, thus limiting the number of users on the system. As a user moves 
further away from the base station, the signal quality decreases, and with it the ability to maintain a high throughput. 
A lower throughput modulation scheme such as QPSK would then be employed. This does not require a large 
group of subcarriers, so the system can support more users. 
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The figure below shows the V2901A SignalMeister 802.16e WiMAX waveform generation and analysis features. 
You can see (background image) a packet structure containing downlink and uplink data, DL and UL, each 
separated by a transition gap. The WiMAX analysis (foreground image) shows some of the measurements that can 
be made for a demodulated waveform. Note that one software application (SignalMeister) includes both the signal 
generation and analysis, and allows the easy addition of signal impairments. 

 
 
 

Beam Forming 
Beam Forming is a signal processing technique used in sensor arrays for directional signal transmission or 
reception. This spatial selectivity is achieved by using adaptive or fixed receive/transmit beam patterns. The 
improvement compared with an omni-directional reception and transmission is known as the receive and transmit 
gain (or loss). 

One of the key benefits of the Agilent V2820A Vector Signal Analyzer and V2920A Vector Signal Generator is their 
ability to align RF energy to specific uses by adjusting the phase and amplitude of each coherent transmitter or 
receiver for beam forming. Beam forming research today is based around developing higher configurations of 
radios within devices to maximize the amount of services that can be delivered to a customer. Radio configurations 
of 8×8 and higher are leading the way in broadband radio research. Agilent Technologies offers the industry's only 
phase-coherent measurement- grade 8×8 system. 
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The Agilent Technologies Inc. V2895A MIMO Synchronization Unit provides synchronized signals to MIMO system 
instruments. This gives the MIMO system a highly precise and stable alignment between up to four signal analyzers 
or signal generators. The V2895A is designed to be used with the Agilent V2820A Vector Signal Analyzers (VSAs) 
and V2920A Vector Signal Generators (VSGs). 

Key features and benefits 
• Synchronization unit creates a MIMO system using standard MIMO-ready Agilent VSAs or VSGs 
• Two, three, or four channel configurations 
• Very wide bandwidth 
• Does not degrade instrument EVM measurements 
• Ideal for 802.11 n WLAN and 802.16e WiMAX Wave 2 
• Same synchronization unit works with both sources (VSGs) and receivers (VSAs) 
• Powerful MIMO signal-analysis software package option 

 

Model 2895 Specifications 
To view the latest version of SPEC-2895, go to www.agilent.com/find/V2895A. 

 

Setting up the V2895A 
To set up the MIMO system: 

1. Connect the system equipment, using the cable configuration shown in the figure below. 
• 100 MHz clock 
• LO signal 
• Sync In signal received from each instrument 
• Sync Out signal sent to each instrument 

http://www.agilent.com/find/V2895A
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10 MHz Ref

Sync Out

LO Out

100 MHz Out
100 MHz Out
100 MHz Out

Even Sec Out

Even Sec In

LO In

LO In

100 MHz InLO In

Master Instrument

Slave Instrument #1

100 MHz In

Even Sec In

V2895A MIMO Synchronization Unit

LO OUT
LO OUT

LO OUT

Sync Out
Sync Out
Sync Out

LO OUT

100 MHz Out

Sync In
Sync In
Sync In
Sync In

10 MHz In

Even Sec Out

100 MHz Out

100 MHz Out

LO Out

Connectors With The Same Name
Are Identical & Interchangable

Connect Other Slave Units 
Same As Slave Unit Above

 
One instrument acts as the leader (or master), and provides all of the instruments in a MIMO system with a 
local oscillator (LO) signal. This instrument is identified as the master LO instrument. The MIMO 
synchronization unit takes the LO signal from the master instrument and distributes it to all the instruments in 
the group (the slaves). 

2. The MIMO system instruments can be powered up at the same time if desired, or individually. 

NOTE: If you power up the instruments individually, power them up in the following order: 

a. V2895A Synchronization Unit(s); these units supply the clock signals for the other instruments 
b. All master instruments 
c. All slave instruments 

 
3. On each VSG, set the following parameters: 

a. Selec t RF: On. 
b. For the master instrument, select Menu > Global Settings > MIMO > Mode > Master > Close. 
c. For each of the slave instruments, select Menu > Global Settings > MIMO > Mode > Slave > Close. 
d. For master and slave instruments, select Menu > Global Settings > Trigger > Trigger Mode > Trigger 

start of Arb waveform > Close. 
 

4.  On each VSA, set the following parameters: 
a. Select Spectrum > General Purpose > Zero Span. 
b. Select Sweep Single. 
c. For the master instrument, select Menu > Global Settings > MIMO > Mode >  Master > Close. 
d. For each of the slave instruments, select Menu > Global Settings > MIMO > Mode > Slave > Close. 
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To Load ARB Waveforms and Synchronize the VSGs 
1. Starting with the Master VSG, load the same arbitrary waveform file into each instrument's waveform playback 

table. 
2. Cho ose Select Modulation > Arb > Add Arb > Add Arb File. 
3. Locate and load the *.arb file: 

• If the file is in the User directory, select the filename and then select Open > Load. 
• If you do not see the file that you want in the User directory, open the Look in: drop-down menu and 

select the directory where the file is located. Select the filename and then select Open. 
4. On each VSG, clear Modulation On to turn off the modulation. 
5. Select Modulation On to turn on the modulation for each of the slave VSGs. 
6. Select Modulation On to turn on the modulation for the master VSG. 

7. Select Menu > Global Settings > Trigger > Trigger Now on each slave VSG to create a trigger event. 

8. Select Menu > Global Settings > Trigger > Trigger Mode > Trigger start of ARB waveform > Close on the 
master VSG. 

 

To Center the Burst across the VSA Display 
On the master VSA, select the following parameters: 

1. Select Menu > Global Settings > Trigger > Trigger Source > Video > Close. 
2. Clea r the BW Auto check box, then double-click Bandwidth > Set to Max. 

 

Adjust the Master VSA to view a complete burst on the VSA display 

1. Select Sweep Time and adjust the value to see a burst on the VSA display. 
3. Visually measure the width of the burst on the screen by counting the number of vertical divisions across the 

displayed burst. 
4. Multiply the number of divisions you counted by the scale per division. Then, set the master VSA sweep time to 

the value calculated in the previous step. 
5. Select Menu > Global Settings > Trigger > Trigger Delay and adjust the delay value to view the entire burst 

on the display. 
6. Select Close. 
7. Select Sweep Single to take a measurement sweep and see if the entire burst is centered on the VSA display. 

If necessary, adjust the sweep time and trigger delay values. 
8. Set the slave VSA’s trigger source, sweep time, and trigger delay settings to the same values that you used for 

the master in the previous steps. 
 

5x5 to 8x8 MIMO Systems 
Systems larger than 4x4 need more ports than one V2895A MIMO Synchronization Unit can supply. Consequently, 
larger systems daisy-chain three synchronization units together. The wiring diagrams for these systems are also 
different as shown in the following diagrams. Two special length SMB cables are used for the center 
synchronization unit's Sync In and Sync Out connectors. These cables are identified in purple on the Sync & 
Trigger Signal Distribution diagram below. 
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Agilent  8x8 MIMO System Components 
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LO Distribution 
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100 MHz Clock Distribution 
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Sync and Trigger Signal Distribution 
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Full Connectivity Diagram 

V2895A

V2895A

V2895A

 
 
 
 

MIMO System Manual Test Procedure 
For testing purposes, there are three types of MIMO configurations: 

• V2920A VSG Only Systems 
• V2820A VSA Only Systems 
• V2920A VSG and V2820A VSA Systems 

Since a defective cable, miswired connection, or an incorrect setting could prevent a MIMO system from working, it 
is best to perform a manual system functionality check.  
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V2920A VSG Only Systems  
Use a oscilloscope to check the RF signals and signal alignment. For a basic functionality check, a 400 MHz or 
better oscilloscope is sufficient. 

1. Connect the VSG RF outputs to the oscilloscope inputs as shown. 
2. Turn on all of the oscilloscope channels that are being used. 
3. Perform the tests as follows. If any of the tests fail, refer to Troubleshooting Tips. 

 
 

VSG Only Systems Step 1 
1. Cycle the power on all instruments. 
2. Check that there are no error messages on the VSG displays. 
3. Press the RF On button on each VSG. 
4. Verify that every VSG is generating a signal. 
5. If any problems are found, go to Troubleshooting Tips for VSG Systems Step 1. 
 

VSG Only Systems Step 2 
1. On each unit create a distinctive waveform so that the signal alignment can be displayed. 
2. On the VSG select Modulation > Digital > ASK > Load.  
3. If ASK is not available you can use Analog > Pulse. You can also use ARB to load a waveform and then set the 

highest possible sample or pulse rate. 
4. Select Edit > Symbols/s > Press the Middle Puck Button to open the number pad > Set to Max > Load > Close. 
5. All VSGs should be generating waveforms that are out of synchronization with each other. If not, go to 

Troubleshooting Tips for VSG Systems Step 2. 
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VSG Only Systems Step 3 

Perform the following sequence on each VSG. 

1. Select Menu > Global Settings > MIMO. 
2. Set the master LO VSG to Master and the other VSGs to Slave and then select Close. 
3. Select Menu > Global Settings > Trigger > Trigger Mode > Trigger start of arb waveform to setup the 

trigger state. 
4. Turn Modulation to off by clearing the checkbox and then select the checkbox to turn Modulation back On 

again. 
5. Once steps 1 through 4 have been done for each VSG, select Trigger Now on each unit.  

All VSGs should start generating waveforms that are in synchronized with each other as shown on the oscilloscope, 
if not go to Troubleshooting Tips for VSG Systems Step 3. 

V2820A VSA Only Systems 
 

A VSG with an RF splitter can be used to create identical RF signals that are fed to each of the VSAs. 

Note: A 1 x 4 splitter is shown in the diagram. If you only have a 1 x 2 splitter available, you can verify two units at 
one time. 

1. Connect the VSG RF Out to the RF Splitter In. 
2. Connect the RF Splitter outputs to the VSAs as shown. 
3. Perform the following tests. 
4. If any of the tests fail, refer to Troubleshooting Tips. 
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VSA Only Systems Step 1 
1. Power cycle all VSAs 
2. Check that there are no error messages on the VSA displays. 
3. Set the source to generate a signal where the alignment can be easily measured. For example, 

• Set RF On. 
• Selec t Modulation > Digital > ASK > Load. 
• Selec t Edit > Press the Middle Puck Button to open the numeric keypad > Symbols/s > Set to Max > 

Load > Close. 
4. .Check that each VSA is receiving the VSG signal. 
5. If any problems are found go to VSA Only Systems Step 1. 

 

VSA Only Systems Step 2 
1. Select Spectrum > General Purpose > Zero Span. To set all of the VSAs to zero span. 
2. Enter a sweep time of 4 ms. 
3. Set the maximum bandwidth (40 MHz). 
4. Select Single Sweep. 

All VSAs should see pulses in the ASK signal, however, the displayed waveforms probably will not be aligned. If a 
problem is encountered, go to Troubleshooting Tips for VSA Systems Step 2. 
 
 

VSA Only Systems Step 3 

On each unit: 

1. Select  Menu > Global Settings > MIMO. 
• for the master LO VSA, select Master.  
• for all other VSAs select Slave. 

2. Select Close. 
3. Set all units to Sweep Cont. 
4. On the master VSA only, select Single Sweep. 

Every time you press the master's Single Sweep button you should see the exact same waveform on all the VSAs. 
If the units freeze or are not synchronized, go to Troubleshooting Tips for VSA Systems Step 3 for help. 
 

VSA Only Systems Step 4 
1. Enable triggered measurements on all VSAs by selecting Trigger > Trigger Source > Video > Close. 

With all the slave instruments set to Sweep Cont., every press of the master's Sweep Single button should 
cause all of the units to take a new triggered trace. 

2. Verify that all waveforms display the exact waveform with identical alignment. If not, go to 
.

VSA Only Systems 
Step 4  
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V2920A VSG and V2820A VSA Systems 
A Combination VSG and VSA system use the VSAs to view the waveforms to verify if both sides of the MIMO 
system are properly aligned. 

1. Connect each VSG to one of the VSAs. The order does not matter. 
2. Go to V2920A VSG Only Systems test procedure to set up the VSGs 
3. Go to  V2820A VSA Only Systems to setup the VSAs. 

 
After performing both the VSG only and VSA only setup procedure, all VSAs should display the exact waveform 
with identical alignment. If you experience problems, go to Troubleshooting Tips. 
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Troubleshooting Tips 
 

Troubleshooting Tips for VSG Systems Step 1 
Problem Possible Causes Possible Solutions 

The VSG’s rear panel 100 
MHz clock is not properly 
connected to the V2895A 
Synchronization unit.  

Check the cable connections. 

The V2895A is not turned on. Check the power light. 

The V2895A was turned on 
later (after instruments were 
turned on.  

The sync unit should be powered on before or at the same time as 
the instruments. The instruments need the 100 MHz clock supplied 
from the V2895A to be already running when they are powered-on. 
If the V2895A is turned on after the instruments are turned on the 
instruments will not start up correctly. 

The VSG's 100 MHz 
input/outputs are swapped or 
mislabeled.  

Check the cable connections. 

At power up the 
VSG reports 
"Could not init 
RF Hardware". 

There is a bad 100 MHz 
cable. 

Replace with a known good cable. 

The VSG LO In is missing. Make sure the VSAs rear panel LO In signal is properly  connected 
to one of the V2895A LO Out connectors. Note: On the bottom of 
the MIMO menu, a LO power indicator is displayed to detect when 
the LO power is too low. 

The master VSG LO Out is 
missing. 

Make sure the master's VSG rear panel LO Out signal is properly 
connected to the V2895A LO In connector. 

The V2895A is not turned on. Check the power light. 

No signal 
appears at the 
VSA output 
when MIMO 
sync is not 
turned on. 

The VSG LO inputs/outputs 
are swapped or mislabeled. 

Check the cable connections. 
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Troubleshooting Tips for VSG Systems Step 2 
Problem Possible Causes Possible Solutions 

The Front Panel RF button 
must be On. 

 

For modulation, the 
Modulation button must be 
On.  

 

One of the VSGs is waiting 
for one of the other VSGs to 
be triggered. 

Trigger all instruments. (That is, if Trigger Source is set to "SCPI or 
front Panel Trigger") select Trigger Now on each VSG then enable 
Trigger start of ARB waveform. 

One of the VSGs does not 
have MIMO Sync turned on. 

Select Menu > Global Settings > MIMO. Set each instrument to 
either master or slave. Then turn RF modulation on and trigger all 
instruments. 

One of the V2895As Sync 
Out lines might not be 
properly connected. 

Make sure all of the VSGs have EVEN Sync In connected to the 
V2895A Sync Out. 

One of the V2895As Sync In 
lines might not be properly 
connected. 

Make sure all of the VSGs have EVEN Sync Out connected to the 
V2895A Sync In. 

The VSG RF 
output or 
modulation 
does not start 
up as expected 
when MIMO is 
enabled. 

One of the Sync cables might 
be bad or shorted. 

Swapping the Sync cables with a known good cable is an option. 
Another option is removing all of the slave units Even Sec Out to 
Sync In cable connections; this will disconnect the slave units from 
the handshaking chain and prevent them from holding up a sweep. 
Then the master can be run to see if it will sweep correctly by itself. 
If it works, then add the slave units back in one by one. This can 
determine if one of these units or its cables is causing the problem. 

 

Troubleshooting Tips for VSG Systems Step 3 
Problem Possible Causes Possible Solutions 

The VSGs might have 
different firmware revisions. 

Load identical firmware into all instruments. 

MIMO sync might not be 
enabled. 

Select Menu > Global Settings > MIMO. Set each VSG to either 
master or slave as applicable. 

The VSG 
outputs are not 
synchronized. 

Triggering might not be 
turned on. 

Select Menu > Global Settings > Trigger > Trigger start of arb 
waveform. Trigger each VSG to start synchronize the outputs. 
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Troubleshooting Tips for VSA Systems Step 1 
Problem Possible Causes Possible Solutions 

The VSA's rear panel 100 MHz 
clock is not properly connected to 
the V2895A Synchronization unit.  

Check the cable connections. 

The V2895A is not turned on. Check the power light. 

The V2895A was turned on later 
(after instruments were turned on.  

The V2895A should be powered on before or at the same time 
as the other instruments. The VSAs need the 100 MHz clock 
supplied from the V2895A to be already running when they are 
powered-on. If the V2895A is turned on after the VSAs are 
turned on they will not start up correctly. 

The VSA's 100 MHz input/outputs 
are swapped or mislabeled.  

Check the cable connections. 

At power up the 
VSA reports 
"Could not init 
RF Hardware". 

There is a bad 100 MHz cable. Replace with a known good cable. 

The VSA LO In is missing. Make sure the VSAs rear panel LO In signal is properly 
connected to one of the V2895A LO Out connectors. Note: On 
the bottom of the MIMO menu, a LO power indicator is 
displayed to detect when the LO power is too low. 

The master VSA LO Out is 
missing. 

Make sure the master's VSA rear panel LO Out signal is 
properly connected to the V2895A LO In connector. 

VSA LO inputs/outputs are 
swapped or mislabeled. 

Check the cable connections. 

No signal 
appears on the 
VSA display. 

There is a bad 100 MHz cable. Replace with a known good cable. 
 

Troubleshooting Tips for VSA Systems Step 2 
Problem Possible Causes Possible Solutions 

One of the V2895A Sync Out lines 
might not be properly aligned. 

 Make sure all of the V2895A “Sync Out” connectors are 
properly connected to each VSA EVEN SEC In connectors. 

One of the V2895A Sync In lines 
might not be properly aligned. 

Make sure all of the VSAs have the “Sync Out” connector 
properly connected to each V2895A “EVEN SEC In" 
connectors. 

The VSA might be waiting for the 
master to trigger with either a 
video or external trigger.  

Check if either external or video trigger is set on the master.  If 
it is set to external trigger, verify that an external trigger is 
being provided. If it is set to video trigger, verify that the video 
trigger level is set properly, or if an input signal that would 
provide a trigger is being input. 

One of the VSAs might not have 
MIMO Sync enabled.  

Select Menu > Global Settings > MIMO. Set the VSA to either 
master or slave as applicable. 

The VSA setup might not be 
correct. 

 Try switching the master VSA out of MIMO mode to see if it 
will operate and trigger on its own. When the setup is corrected 
go back into MIMO mode. 

The VSAs hang 
up and do not 
sweep. 

One of the Sync cables might be 
bad or shorted.  

Swapping the Sync cables with a known good cable is an 
option. Another option is removing all of the slave unit's Even 
Sec Out to Sync In cable connections; this will disconnect the 
slave units from the handshaking chain and prevent them from 
holding up a sweep.  Then the master can be run to see if it 
will sweep correctly by itself.  If this works, the slave units can 
be added back in one by one.  This can be done to determine 
if one of these units or cables is causing the problem. 
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Troubleshooting Tips for VSA Systems Step 3 
Problem Possible Causes Possible Solutions 

The instruments might have 
different firmware revisions. 

Load identical firmware into all instruments. 

MIMO sync might not be 
enabled. 

Turn on under Menu > Global Settings > MIMO. While all 
instruments are in "hold" (not sweeping), set to either master or 
slave as applicable. 

Triggering might not be set to 
the exact same mode on all 
instruments. 

Set all instruments to the same triggering mode. Select Menu > 
Global Settings > Trigger. Note that instruments configured as a 
slave will ignore this setting and obtain their triggering from the 
master, but this trigger setting still needs to be set to the same 
selection on all instruments. 

One of the V2895A sync units 
"Sync Out" lines might not be 
properly connected. 

Make sure all of the V2895A Sync Out connectors are properly 
connected to each receiver’s EVEN SEC IN connectors. 

The instruments 
are not 
synchronized. 

MIMO mode might have been 
enabled when the receivers 
were in different states. 

Switching receivers in MIMO mode while some receivers are 
sweeping or in different instrument states may put the instrument 
out of synchronization with each other. To fix this, place all of the 
instruments in hold (Sweep Single). Next, place all of the receivers 
into the same instrument state, and then switch all receivers into 
MIMO mode.  

 

Troubleshooting Tips for VSA Systems Step 4 
Problem Possible Causes Possible Solutions 

The instruments 
are not 
synchronized. 

Triggering might not be set to 
the exact same mode on all 
instruments. 

Set all instruments to the same triggering mode. Select Menu > 
Global Settings > Trigger. Note that instruments configured as a 
slave will ignore this setting and obtain their triggering from the 
master, but this trigger setting still needs to be set to the same 
selection on all instruments. 

 

MIMO Debugging for Control Software 
Problem Possible Causes Possible Solutions 

Instrument address is 
incorrect 

With multiple instruments it is easy to have one instrument address 
wrong. Use the instrument front panels to bring up the addresses 
and make sure they match the addresses entered into the control 
software. 

Cables are not properly 
connected 

Ensure that all communications cables are present, fully inserted, 
and latched or fastened. 

Bad cable Try swapping cables with an instrument that is able to communicate 
to see if the cable is defective. 

One or more 
instruments do 
not respond to 
remote 
commands. 

Instruments do not respond Cycle the power on all instruments. 
The sources are transmitting 
a non-MIMO ARB file.  

A MIMO ARB file contains channel information for each 
source/antenna, but that information is missing from a non-MIMO 
ARB file. 

MIMO decoding 
software cannot 
detect all of the 
MIMO 
channels. Some sources have been 

loaded with the same MIMO 
ARB file.  

To emulate multiple MIMO transmit channels, or antennas, it is 
necessary to use unique ARB files in each source. MIMO ARB files 
contain channel information and each source must use an ARB file 
that broadcasts different channel information. 
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MIMO Signal Descriptions and Troubleshooting Tips 
Signal Descriptions Troubleshooting Tips 

The 100 MHz clock is used to run the 
instrument's internal hardware.  This is provided 
so the clocks in every instrument in a MIMO 
group will run in synchronization. 

Since this clock runs the instrument's internal hardware, if this 
signal is not connected to the instrument (or if the v2985A is turned 
off) the instrument will not run and display the error "Could Not Init 
RF Hardware". 

The common LO Carrier signal is provided by 
the "master LO" instrument, and is distributed 
back to all instruments so every instrument's 
carrier phase is synchronized exactly and does 
not deviate or jitter. 

If this signal is not correctly connected, an instrument will not 
generate a signal at its RF output port.  
On the V2895A menu, a LO power indicator is displayed to detect 
when the LO power is missing.   
Since the LO signal is common to all of the instruments, "slave" 
instruments must be set to the identical instrument configuration 
settings as the "master" instrument, or "slave" instruments will not 
use this LO signal correctly. 

The V2895A's "Sync In" input signal informs the 
V2895A when an instrument is ready to proceed.  
The signal runs from an instrument's "Even Sec 
Out" port to one of the V2895A's "Sync In" ports.  

If an instrument is not in MIMO mode, or if the instrument is not 
programmed correctly, then this "ready to proceed" signal might be 
in the wrong state, which could prevent the MIMO group from 
starting. 

The V2985A’s "Sync Out" signal tells the 
instruments when to start generating signals (for 
VSGs), or when to start or end measurements 
(for VSAs).  It connects to the instrument’s "Even 
Sec In" port. 

An instrument might freeze and refuse to trigger in MIMO mode if 
this signal is not properly connected. 
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Introduction to SignalMeister™ 
The Agilent V2901A SignalMeister RF Communications Test Toolkit is a PC-based software tool that allows you to 
easily create and analyze complex signals used in advanced wireless transmission protocols.  

SignalMeister software works seamlessly with Agilent Series V2900 Vector Signal Generators, Series V2800 
Vector Signal Analyzers, and MIMO test systems. 

Using a waveform file created with SignalMeister software requires one or more Series V2900 VSGs equipped with 
an arbitrary waveform generator (ARB) option and a SignalMeister license option that matches the waveform signal 
standard of the file being used. 

 Analyzing the signals created by the waveform files requires a Series V2800 VSA equipped with the appropriate 
license options, or a SignalMeister Signal Analysis license. There are two SignalMeister signal analysis software 
licenses available: The WLAN Analysis license (V2901A-WLN) and the WiMAX Analysis License (V2901A-WMX).  

Supported Wireless Transmission Formats 

WLAN 
802.11a/g/j/pj 
802.11b 
802.11n MIMO 
802.11n SISO 

WiMAX® 802.16e OFDMA 

3GPP 
W-CDMA 
HSDPA 
HSUPA 

3GPP2 
cdma2000® 
cdmaOne® 
1xEV-DV 

DVB DVB-T 
DVB-H 

 

Note: All Agilent Series V2900 vector signal generators require firmware revision 3.11 or higher to be 
compatible with Agilent V2901A SignalMeister RF Communications Test Toolkit. 

 

 

 
To learn more detail about using SignalMeister software, refer to the SignalMeister Help system. 
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Application Interface Overview 
When the Agilent V2901A SignalMeister RF Communications Test Toolkit is first launched, the user interface 
displays the default docking station layout shown below. 

 
 

Each of the windows has a docking function, allowing each of the windows to be docked in a new location, hidden 
from view, or “floating” allowing them to be moved to any convenient location on the screen. 
 

NOTES:  • To restore the default docking layout to the application interface, select View > Restore Docking 
Layout from the Menu Bar. You can also restore the layout for individual windows from the View 
menu. 

 • SignalMeister’s analysis feature cannot be operated using Desktop Control Panel. 
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SignalMeister licenses 
Displays the licenses available on your <SM> RF Communications Test Toolkit. The SignalMeister  permanent 
license key serial number is also displayed. If you are using an evaluation license key, the expiration date of the 
key is displayed. Contact your <company> representative about adding other licenses. 

 
 

Signal Generation Software Licenses 
The Series V2900 Vector Signal Generators can play back waveforms that are generated from the SignalMeister 
RF Communications Test Toolkit when the correct licenses are installed. To play back a SignalMeister software-
generated waveform with a specific channel added and "Enabled" in the SignalMeister signal definition dialog box, 
you will need to have both the correct type of waveform playback license and a valid arbitrary waveform generator 
license loaded on your Series V2900 VSG. 

To view the current instrument option licenses on the Agilent Series V2800 VSA and the Series V2900 VSG, select 
Menu > Utilities > Licensing from the front panel of the instrument. 

To view the current SignalMeister licenses select File > Manage Licenses from the SignalMeister main menu. 

See the following tables for available licensing options. 

WLAN Licensing 

License Model Number License Identifier Waveform Types Additional Licenses Required 

V2900A-205 802.11a/b/g/j Signal Generation 802.11a, b, g, j V2920A-B20 * 

V2900A-206 802.11N Signal Generation (MIMO 
and SISO) 

802.11n V2920A-B40 * 
V2900A-205 

V2900A-207 802.11N Channel Modules  
A through F 

WLAN V2920A-B40 * 

* Minimum ARB generator bandwidth. The ARB number may be larger, for example, V2920A-B20 may use V2920A-B40 or 
V2920A-B80. 

WiMAX® Licensing 

License Model Number License Identifier Waveform Types Additional Licenses Required 

V2900A-208 802.16E Signal Generation 802.16e-2005 V2920A-B40 * 

V2900A-209 802.16E Channel Model Signal 
Generation 

802.16e-2005  

*  Minimum ARB generator bandwidth. The ARB number may be larger, for example, V2920A-B40 may use V2920A-B80. 
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3GPP Licensing 

License Model Number License Identifier Waveform Types Additional Licenses 
Required 

V2900A-202 WCDMA Signal Generation WCDMA V2920A-B20 * 
 

V2900A-204 3GPP Channel Model Signal 
Generation 

  

V2900A-203 ** HSPA Plus Signal Generation 
(uplink and downlink) 

HSDPA 
HSDPCCH 
HSDPAFRC 
HSUPA 
HSUPAFRC 
EHICH 
ERGCH 
EAGCH 

V2920A-B20 * 
V2900A-202 
V2900A-105 

* Minimum ARB generator bandwidth. The ARB number may be larger, for example, V2920A-B20 may use V2920A-B40 or 
V2920A_B80. 

** If you have the previous HSPA licenses, 2900-HSDPA-PC and 2900-HSUPA-PC, either one of these will enable the same 
functionality as V2900A-203. 

3GPP2 Licensing 

License Model Number License Identifier Waveform Types Additional Licenses 
Required 

V2900A-201 CDMA Signal Generation cdmaOne 
cdma2000 
1xEV-DV 

V2920A-B20 * 
V2900A-104 

*  Minimum ARB generator bandwidth. The ARB number may be larger, for example, V2920A-B20 may use V2920A-B40 or 
V2900A_B80. 

Multi-Purpose Licensing 

License Model Number License Identifier Waveform Types Additional Licenses 
Required 

V2900A-213 DVB Signal Generation DVB-H 
DVB-T 

V2920A-B20 * 

* Minimum ARB generator bandwidth. The ARB number may be larger, for example, V2900A-B20 may use V2900A-B40 or 
V2920A_B80. 

Signal Analysis Software Licenses 

The V2901A SignalMeister RF Communications Test Toolkit software can be used to perform signal analysis 
functions when the correct licenses are installed in SignalMeister. The signal analysis licenses reside in the 
V2901A SignalMeister USB license key. 

License Model Number License Identifier Waveform Types Additional Licenses 
Required 

V2901A-WLN WLAN Analysis 802.11a,b,g,j,n-SISO 
802.11n-MIMO 

none 

V2901A-WMX WiMAX Analysis 802.16e-2005 none 

For more information about purchasing SignalMeister licenses, please visit the SignalMeister support page at 
http://www.agilent.com/find/V2901A. 
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Basic SignalMeister Tasks 
 

Working with Elements 
NOTE: The elements provided in the Toolbox groups are samples that you can use as they are, or you can 

customize them for your particular testing needs. When viewing elements in the toolbox, remember that 
an element's label only indicates its present configuration. You can place an element on your worksheet 
and modify its properties as you see fit. If you modify an element, we suggest you edit the element’s label 
so that it more accurately indicates how you have customized it or its relevance to your project. 

The elements in the SignalMeister toolbox are the building blocks used to: 

• Define and process an arbitrary waveform file in one of the several available signal formats, 
• create a waveform file based on your configuration; 
• download that waveform file to a signal generator to be played back and analyzed.  

Each element, or icon, represents a specific function, or portion, of the waveform creation and playback process, 
and has a configuration dialog associated with it that allows you to set the parameters for that particular element, 
based on what the element represents. For example, the FFT size, bandwidth, guard interval, and so on, in a 
WiMAX® waveform can be configured for your specific waveform design, renamed to easily identify that particular 
configuration, and then saved to be used again to create other ARB files using a WiMAX element from the Toolbox. 

To access the configuration dialog of any element, either double-click the element icon or right-click the element 
icon then select Edit Element Configuration... from the pop-up menu (below). 

Other items from the right-click menu include: 

Menu Item Function 

Edit Element 
Configuration...  

Opens the configuration dialog window of the selected 
element. 

Save Element as 
User Template... 

Opens a dialog window that allows you to save the selected 
element as a user template. The dialog window provides you 
the opportunity to specify a template name and location for the 
saved element. The template is displayed in the My Templates 
toolbox with the icon of the selected element. 
NOTE: If the user template is stored in any location other than 

C:\Program Files\Agilent Technologies\Agilent 
SignalMeister\Item Templates\User Templates, it will 
function as a template, but will not be shown in the My 
Templates toolbox. 

Rename element... Opens the Rename dialog that allows you to change the name 
of the selected element.  

Cut Removes the selected element from the worksheet and places 
it on the system clipboard. 

Copy Places a copy of the selected element on the system 
clipboard. 

Delete Deletes the selected element. 

Run conflict 
analyzer 

Runs the conflict analyzer only on the selected element, not 
the entire worksheet. This is particularly valuable when 
checking for channel and code conflicts. 
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Connecting Elements 

Select the Connect Elements icon  in the tool bar to begin the sequence of connecting one or more elements 

together in your project. When Connect Elements is active , begin by selecting the sink element, then select 
the source element to connect the two items. You can drag and drop multiple elements onto your worksheet, then 
connect them all as one step.  

For example, to connect a WiMAX element, an ARB File element, and a 2900 VSG element together you would: 

1. Drag and drop the elements from the Toolbox to the Projects worksheet. 

 
4. Select the Connect Elements button to make it active. 

 
5. Click the WiMAX® element. 
6. Click the ARB file element (these are now connected). 

 
7. Click the ARB file element again. 
8. Click the signal generator element (all three elements are now connected). 
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Renaming Elements 

NOTE: The elements provided in the toolboxes are samples that you can use as they are, or customize for your 
particular needs. When viewing elements in the toolbox, remember that an element's label only indicates its 
present configuration. You can place an element on your worksheet and modify its properties as you see 
fit. If you modify an element, we suggest you edit the element’s label so that it more accurately indicates 
how you have customized it or its relevance to your project. 

 
Select Rename Element to assign a unique, easy to remember name for your element. This is particularly useful 
after you have customized the settings for any element, and want to save those changes for future use. 

 
 

Creating an Element Shortcut 
1. In the Worksheet, click on a element or a group of elements to highlight 
2. Right-click on the element and select Copy from the shortcut menu. 
3. From the main menu, click Worksheets > Paste as Shortcut. 

Notice that the new element or group of elements has a yellow boarder identifying it as a shortcut. 
 

Using the Frequency Shift Element 

SignalMeister generates signals at the baseband frequency. When they are played back on the V2900 Vector 
Signal Generator (VSG), their frequency spectrum is centered on the carrier frequency of the VSG.  

Ideally, to generate interferer or jamming signals, you would use multiple VSG instruments. However, if you have 
only a single VSG you can generate a single ARB file with both a desired signal and an interferer, with some 
limitations. The jamming signal can only be a maximum of half the ARB generation bandwidth away from the carrier 
frequency. Additionally, you will run into resolution issues of the DAC, impairing the signal quality. 

Example project 

The following example uses an 802.11 WLAN signal in the presence of an identical 802.11 WLAN signal on an 
adjacent channel 50 MHz away. 

Start with an 802.11a,g signal object that is shifting by 20 MHz. This signal must be unsampled, because at the 
default 50 Msample/s rate used for two 802.11 signals, you are limited to a 40 MHz bandwidth. Shifting a 20 MHz 
wide 802.11 waveform by 20 MHz would not be possible, because you would be bandwidth limited (20 MHz offset + 
20 MHz BW/2 = 50 MHz). Unsampling to 100 Msamples/s allows you to generate waveforms with bandwidth up to 
80 MHz total. (That is, 40 MHz offset from each side of the carrier.  

Next, the interferer is generated. A frequency shift element with a 20 MHz value is inserted. The output of the 
resampler is connected to both the frequency shift element and to the channel model element. The channel model 
element allows you to combine both the frequency-shifted and original 802.11 a,g signals into a single ARB file. 
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Step 1 

Build the project using an 802.11a,g 54Mbps signal with the other elements as shown below. 

 

Step 2 

Use the Channel Model Configuration to combine main signal with the frequency shift module (3 dB down). 

 

Step 3 

Add a VSA Simulator and General Purpose Analysis elements to the project as shown below. 
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Step 4 

Use the General Purpose Analysis element to view the results. 

 
 

Managing Project Files 
SignalMeister uses various file types when creating and executing projects. For example: 

• Project files (*.ksmp) 
• Component files, such as ARB files, map files, IQ files, bit reference files, and other data files. These can be a 

combination of files generated or referenced relative to the project directory, or referenced from an external 
source (for example, residing on another part of the hard drive, on a network drive, etc.). 

____ 
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IMPORTANT:  
If you intend to share or move your SignalMeister projects (for example, email or move them to another 
computer), be sure to keep all the files located in the same directory as the project (*.ksmp) file, or a 
subdirectory of the project. 
 

Regardless of how a project is saved or the component files are specified, if all the files are in the same 
directory as the project, or in a subdirectory of the project, then you can copy that directory (and 
subdirectory) to any other location and successfully open and use the project from the new location, 
including a different computer. 
 

However, if a SignalMeister project uses any component file (ARB file, map file, etc.) that is specified in a 
location other than the project's directory (or subdirectory), then that file must exist in that exact absolute 
path for that project to be opened and used successfully. 
 

For example, if you save a project in C:\MyProject and it specifies that the component files also reside in 
C:\MyProject\components, you can compress/zip the entire MyProject directory and move/send it to another 
computer, where it can be uncompressed/unzipped and used in any location. 
 

Conversely, if you save a project in C:\MyProject and it specifies a user file in your computer's My 
Documents directory (for example, c:\documents and settings\johndoe\My Documents\) and you send all the 
files to another computer, the project will report a conflict because the specified user file cannot be found 
(c:\documents and settings\johndoe\My Documents\ does not exist on the other computer). 

Renaming Project Worksheets 
There are three ways available to rename the project worksheets; from the Worksheets menu in the menu bar, 
double-click the worksheet tab to highlight the worksheet name and type in the new name, or right-click the 
worksheet tab and select Rename Worksheet from the drop-down menu. The following steps explain how to 
rename a worksheet from the menu bar. 

1. From the main menu, select Worksheets > Rename Worksheets.  
2. In the Rename dialog box, enter a new name for the current worksheet.  
3. Select OK. 

Creating Project Templates 
Any portion of a SignalMeister project can be saved as a user template allowing easy reuse of project elements. 
For example, after you have entered the communication addresses for the signal generator and signal analyzer, 
you could save this to reuse in future projects. 

As you configure different test setups, you can save any element, group of elements or complete project as a 
template. When you first open the SignalMeister software, the My Templates category is not immediately available 
in the Toolbox, and there are no templates available for use. As soon as you save either a project or an element as 
a template, the My Templates category is displayed with the saved template available to use in your project. 

There are two types of templates for use in SignalMeister; a project template (*.ksmp), and an element template 
(*ksmt): 

• A project template is made up of two or more individual elements, and is identified by a green, template icon, as 
shown in the figure below. 

• An element template is a single element that has been configured for your specific needs, and has been saved 
with that configuration. It is identified by the element icon from which it was created, as shown in the figure 
below. 

NOTE: Only single elements can be saved as an element template. If you want to save more than one element 
as a template, it must be saved as a project template with the project (*.ksmp) file extension. 
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Saving a template 
1. To save an existing project as a template, right-click anywhere in the Projects worksheet and select Save 

Project as Template… from the context menu. Alternately, from the main menu select Projects > Save Project 
as Template.... 

2. To save an existing element (configured for future use), right-click on the element and select Save Element as 
User Template… from the context menu. Alternately, from the main menu select Elements > Save element as 
User Template.... 

3. After the template is saved, SignalMeister automatically creates a "My Templates" group in the Toolbox and 
places the template in it. In the Toolbox select My Templates to view the new user-saved project template or 
element template. 

 
 

Adding a template to a project 

User template elements can be added to projects like any other elements. Once the user template is placed in a 
project, it will expand into all of the individual elements included in the template. To demonstrate this feature: 

1. From the main menu, select Worksheets > Add Worksheet to add a new worksheet into the existing project.  
2. Right-click on the Sheet 2 tab and select Rename Worksheet. You rename the worksheet for easy identification 

of the signal types and ARB file configurations. 
3. In the Toolbox, select the template element from the My Templates folder and click and drag it across to the 

new worksheet. 

Notice how the project element expands back into the three individual elements that were saved as the project 
template. 
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Deleting a template 

To delete a user template, perform the following steps: 

1. From the main menu bar, select Elements > Delete User Templates. 
2. From the submenu, select the name of the user template you want to delete. 
3. As soon as you click the name of the template you want to delete, it will be removed from the My Template 

category. 

Printing a Worksheet 
1. From the main menu, select File > Print Worksheet...  
2. From the Print dialog box, select the printer name and specify the Properties if needed.  
3. Select OK. 

Tip: You can add descriptive text to a worksheet prior to printing.  

1. From the main menu, select Elements > Add Text Block.  
2. An editable text box appears in the center of the worksheet.  
3. Double-click inside the text box to open the Text Block Editor.  
4. Enter the desired text and then select OK.  
5. In the Worksheet, click and drag the text box to the desired location. 
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Generating ARB Files 
The basic process for creating waveforms is described below. 

1. Drag and drop a signal generation element from the Toolbox onto the Projects worksheet. Choose from one of 
the available technologies, such as WLAN, WiMAX, 3GPP, 3GPP2, Digital Video, and so on.For this example, 
the WLAN 802.11a, g 54 Mbps is used. 

 
2. Double-click the element or right-click on the element and select Edit Element Configuration… from the 

context menu to set the waveform parameters. The 802.11a,g,j,p Configuration dialog is displayed. 
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3. From the Files section of the Toolbox, click and drag an ARB File element onto the Projects worksheet. 
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4. Use the Connect Elements icon  (shown in the tool bar as a line with arrow heads on both ends) to 
connect the output of the waveform element to the input of the ARB file element. To do this, first click the 
source element then click the sink element to automatically connect them. In this step the source element is the 
WLAN element, and the sink element is the ARB File. 

 
 

5. Double-click the ARB File element to open the ARB File Configuration dialog and enter the ARB file name and 
storage location on the PC. 
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6. From the main menu, select Project > Build All to build the ARB file. When the build is complete, the Status 
area displays a results message. Notice that the elements in the worksheet turn color. In this case, the 
background color changes to green, indicating that the element ran without any errors or warnings. Yellow 
indicates that the element ran with warnings; Red indicates that the element had errors and the build was 
halted.  

 
At this point, the ARB file is generated and can be loaded into the Series V2900 vector signal generator (VSG). 
The file can be manually moved using a USB memory device or you can use SignalMeister to copy the ARB file 
to the VSG. 
 

7. To save the project select File > Save Project As. You can reload saved projects into SignalMeister at a later 
time. 
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Importing ARB and IQ Files (user-provided files) 
SignalMeister can import a double- or single-precision IQ file and convert it into an ARB file for use with the Agilent 
Series V2900 Vector Signal Generators, as well as importing ARB files that were previously created and saved. 
The following instructions show how to import an IQ file, convert it to an ARB file that is saved to a file for future 
use, then import that ARB file into a project. 

IMPORTANT: To play the ARB files created in this process, you must have a V2920A-Bxx ARB file 
playback license, either V2920A B20, V2920A B40 or V2920A B80, based on the sample 
rate. Less than 50 Msps requires a 20 MHz license, 50 Msps to 99 Msps requires a 40 MHz 
license and 100 Msps or greater requires an 80 MHz license. See Managing Licenses for 
more information on obtaining and installing licenses. 

1. Drag and drop the elements shown in the diagram below onto a project worksheet and connect them as shown. 
See Connecting Elements. 

 
2. Double-click the DP IQ Import element to open the dialog, then enter the information about the file you want to 

import.  
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3. Right-click on the first instance of the ARB File element, select Edit Element Configuration from the popup 
menu, then enter a name for the ARB file and the location where you would like to save the file in the Arb File 
Name field. Click OK 

 
4. Right-click on the first instance of the ARB File element and select Build from the popup menu. 

 
5. When the build is finished, the IQ Import and ARB File elements become green in color, indicating the .bin file 

has been converted into an .arb file without errors. 
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6. Double-click the ARB File Importer to open the dialog, then enter the Arb File Name and location of the ARB file 
you saved in Step 3 

 
7. Right-click on the second instance of the ARB File element, select Edit Element Configuration from the 

popup menu, then enter a name for the ARB file and the location where you would like to save the file in the 
Arb File Name field. Click OK. 

 
8. Right-click on the second instance of the ARB File element and select 

Build from the popup menu. 

 

 

 

 

 

9. When the build is finished, the ARB File Importer and ARB File elements 
become green in color, indicating the .arb file was imported without 
errors. 

 

10. The ARB file is now ready to use in other projects. 
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Downloading ARB files to a Series V2900 VSG 
The Agilent V2901A SignalMeister RF Communications Test Toolkit allows you to create arbitrary waveform files 
(ARB) for Agilent Series V2900 signal generators and play them on Series V2800 vector signal generators. 

1. To copy the arb file automatically, add a signal generator element to your project by dragging and dropping a 
signal generator element from the Toolbox to the Project worksheet. 

2. Enter the LAN or GPIB address for the instrument. To open the configuration dialog window, use either of the 
two methods below: 

• Right-click the signal generator element and select Edit Element Configuration from the context menu. 
• Double-click the selected signal generator element. 

3. Select the VISA Resource tab, and then select the Configure button. If you are using a LAN connection, 
select the LAN/TCPIP tab. If you are using a GPIB connection, select the GPIB tab. 

4. Enter the TCP/IP address of the signal generator. The LAN/GPIB addresses for the <Series> Vector Signal 
Generators are viewed or set from the Utilities menu of the signal generator. From the front panel of the signal 
generator select Menu > Utilities > Ethernet Settings... to view the IP address. 

5. After the IP address has been configured, connect the Signal Generator element by selecting the Connect 
Element icon in the toolbar, then select the arb file and the signal generator on the worksheet. 

6. The arb file can now be downloaded and played by the signal generator using one of the methods shown 
below. 

• Selec t Project > Load All from the main menu 
• Select the Load All button from the Project toolbar 
• Right-click the signal generator element and then select Load Arb File from the context menu. This 

method allows you to update only one arb file if you have several configured in a large project. 
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Adding Modifications and Impairments to ARB Files 
Modifications and impairments can be added to any type of ARB file by sending the output or the waveform 
generation element to an operation element before sending it to the ARB file element. Multiple modifications can be 
added to the same signal. Modification and impairment elements are contained in the Operations section of the 
toolbox. The available waveform operations include: 

• AWGN 
• IQ gain imbalance 
• IQ offset 
• Invert Q signal 
• Resample to a different sample rate 
• Apply a channel matrix to a MIMO signal 

 

As an example, an AWGN will be added to the signal in the existing WLAN project.   

1. From the Toolbox, select the Operations tab and click and drag the AWGN element to the project. 

 
2. Use the Connect Elements icon to connect the 802.11 signal element to the AWGN element.  
3. Double-click on the AWGN element to set the noise level. 

 
At this point, there are two options. 
• First you can disconnect the output of the 802.11 signal generation element from the ARB file element and 

connect the output of the AWGN element to the ARB file input.   
• Or, you can create a second ARB file for the impaired waveform. The ARB file and signal generator 

elements can be added to the project from the toolbox, as shown earlier, or you can select the existing 
ARB file and signal generator elements in the project and copy them.   
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4. To do this, on the worksheet click and drag a rectangle over the ARB file and signal generator elements to 
select. 
 

5. From the main menu, select Elements > Copy then Worksheet > Paste as New. 

 
 

6. Use the Connect Elements icon to connect the output of the AWGN element to the new ARB file as shown in 
the figure above. 

7. Double click on the new ARB File element to open the ARB File Configuration dialog, and then enter a file 
name. 

 
8. Double-click on the signal generator element and configure the communications settings for the signal 

generator communications type used. 
 

The project now illustrates the two methods for generating and downloading the ARB files. If you select Project > 
Force Load All, both files will be generated and loaded. If you right click on the new source element and select 
Load ARB File, only this file will be downloaded. 
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Communicating with Signal Generators and Signal Analyzers 
Refer to Generating ARB Files for details on how to create an ARB file. 

1. To Copy an ARB file automatically, add a signal generator to the project. Note this topic continues with th 
e802.11a,g 54 Mbps setup described in Generating ARB files. 

 
 

2. Either double-click on the signal generator element, or right-click and select Edit Element Configuration, to 
open a dialog window where you enter the LAN or GPIB address, configure the Arb file, or start the LXI Web 
Interface for that signal generator. 
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3. Select the VISA Resource tab, and then click Configure.  

 
 

4. Select either the LAN/TCPIP or GPIB tab as applicable, then configure your interface setup. Click OK when 
you have finished..  
The GPIB and LAN addresses for the Series V2900 Vector Signal Generator or the Series V2800 Vector Signal 
Analyzer are s obtained from the Utilities menu of the instrument to which you want to connect. The following 
screen capture shows the LAN setup screen for the instrument. The instruments allow static and dynamically 
allocated LAN addresses. 
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5. Now that the communications address is configured, use the Connect Elements icon to connect the Signal 
Generator element to the output of the ARB file. 

 
 
The ARB file can now be downloaded and played by the VSG using two different methods. 

• From the main menu, select Project > Reload All. This will regenerate the ARB files and then load 
them to the VSG. 

• Right-click on the Signal Generator element and select Load ARB File from the context sensitive 
menu. 

For this simple project, there is no difference between these methods. However, SignalMeister allows the 
creation of a large project that can produce multiple ARB files. For these projects, the second method 
allows you to update one file without regenerating all of the files in the project. 
 

6. When you select either method a dialog will be presented asking you to load or overwrite the existing files.  
Select OK to these dialogs to load the new file. The Signal Generator element will also turn color after the 
above process. A green background indicates that the operation completed successfully. 

 

USB memory device 
1. Insert a USB memory device into a USB port on your computer. 
2. Copy the generated waveform file (*.arb) to the memory device from the storage location of your PC. 
3. Remove the USB memory device from the computer and insert it into the Series V2900 VSG front panel USB 

port. 
4. From the Series V2900 VSG front panel, choose Select Modulation > Arb > Add Arb > Add Arb File. 
5. In the Open Arb dialog box, select the Look in: drop-down arrow and select USB. 
6. Select the *.arb file from the scroll list and select Open. The file is now loaded in the arbitrary waveform 

playback table. 
7. Select the row of the playback table containing the file that you just downloaded, then select Load Row#. 
8. Select RF: On to switch on the RF output.  

For more information on signal control and playback, refer to the Series V2900 VSG help topics. See Arbitrary 
waveform > Arbitrary waveform procedures for detailed information. 
 

Agilent V2895A MIMO Synchronization Unit 
MIMO Application Guide 63 



Section 3: Using SignalMeister™ 

Using the LXI Web Interface 

SignalMeister also allows a convenient method to access the LXI Web Interface for Agilent RF instruments. To 
access the LXI interface, double-click the source element (refer to Communicating with Signal Generators and 
Signal Analyzers select the LXI Web Interface tab and then select Start LXI Interface. 

 
The Agilent LXI interface has two very useful operations in this mode. First you can select a live display of the 
instrument. The following figure shows the vector signal analyzer welcome screen. 

 
 

The LXI interface screen capture can also be useful to copy the instrument display for report and data sheet 
generation. 
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Working with Analysis Elements 
Print/Copy/Save Analysis Elements 

This menu is specific to the analysis elements (Displays > Print/Copy/Save 
Displays), and provides access to the Print/Copy/Save commands for each 
of the active displays. 

As displays are made active or are disabled, such as the parameters table, 
burst data table, and graph or strip chart displays, the list of Current Displays 
is updated as each is added or removed. Use the check-box(es) to select the 
items you wish to Print/Copy/Save. 

 

 

 

 

Command Description 

Copy Each To Clipboard Copy each of the selected displays to the clipboard. 

NOTE: When the contents of the Parameters Table is copied to the clipboard, it 
can be pasted as tab delimited text into applications such as Notepad®, or 
it can be pasted as comma separated values (CSV) into applications such 
as Excel®. 

Print Choose this to print the selected displays. 

Print Preview Select this to preview the current print job. 

Save to PDF Select this to save the selected displays to a PDF file. 

Monochrome Select this check-box to have each selected display shown in monochrome (black 
and white). De-select this check-box to show the displays in color. 

 

Setting Up the Analysis Window 

From the Analysis Window, individual windows can be selected from both the Displays Menu and the Settings 
Menu. Once selected, the positioning and some properties of the window can be set up using the View Menu. 
 

Set Up Windows 

To set up a window in Analysis Window element, do the following: 

1. Launch the Analysis Window. 
2. Select either Displays Menu or Settings Menu. 
3. Select a window from the menu. 

Example: Displays > Graphs > Constellation, or Settings > Instrument Control 

NOTE:  The selected window opens in accordance to the settings in the View Menu with regard to position and 
size. 
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Arranging Windows 

If the windows are docked, there are several methods of arranging them. 

 

Docking Windows 

To dock a window: 

1. Right-click the graphical area of the display below the title bar. 
2. Select Dock to. 
3. Select either Left, Right, Top, or Bottom as the edge of the graph to dock to. 

 
 

 

 

 

Un-Docking Windows 

To Un-Dock a window: 

1. Right-Click the graphical area of 
the display below the title bar. 

2. Clear the Docking selection. 

The Constellation window 
docks to the left side of the 
analysis window. 

3. The window is now free to be moved by dragging. 
 

Hiding Windows 

To hide a window: 

1. Right-click the graphical area of the display below the title bar. 
2. Selec t Hide. 
3. The window now disappears from view. 
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Signal Generation 
The input parameter requirements for different communication standards vary significantly. As such, the displays 
for inputting this data in SignalMeister also vary significantly. The SignalMeister waveform parameter input screens 
are formatted in a manner that allows data entry consistent with the terminology of the standards. 

• WiMAX 
• WLAN 
• 8 x MIMO Signal Generation – IQ files 
• 3GPP and 3GPP2 

NOTE: For more detailed information on signal generation refer to the V2901A SignalMeister Help system. 
 

WiMAX 
The 802.16e WiMAX standard allows for a very high degree of flexibility. The SignalMeister parameter window for 
WiMAX also allows this level of flexibility. There are three major sections of the WiMAX setup: 

• Common Parameters: Specifies the input parameters such as FFT size, number of symbols, length of frame, 
It also allows you to create the uplink or downlink signal.  

• DL subframe: Specifies the zone and burst parameters for the downlink subframe. 
• UL subframe: Specifies the zone and burst parameters for the uplink subframe. 
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Because of the complexity of the WiMAX map configuration, SignalMeister can save the map configuration into a 
file that can be loaded into the signal analyzer. The WiMAX Map file element is located in the Files folder of the 
toolbox. The output of the Map File element can be connected to a signal analyzer element and is loaded into the 
VSA WiMAX measurement when the project is run. The following examples show this setup. 
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Generating a WiMAX SISO Signal 

Put Elements in the Project View 
1. In the SignalMeister Toolbox, select the WiMAX folder to display the list of WiMAX elements. 
2. Drag and drop DL 10 MHz, 1024 FFT into the Projects view. 
3. In the Toolbox, select the Files folder to display the list of Files elements. 
4. Drag and drop the ARB File and WiMAX Map File elements into the Projects view. 
5. In the Toolbox, select the Signal Generators folder to display the list of signal generator elements. 
6. Drag and drop a 2900 VSG element into the Projects view. 
7. In the Toolbox, select the Signal Analyzers folder to display the list of signal analyzer elements. 
8. Drag and drop a 2800 VSA into the Projects view. 

 

Connect the Elements and Run the Project 
1. Use the Connect Elements icon to connect the output of the DL 10 MHZ, 1024 FFT element to the ARB File 

input. 
2. Connect the output of the ARB File element to the input of the 2900 VSG element. 
3. Connect the output of the DL 10 Mhz, 1024 FFT element to the input of the WiMAX Map File element. 
4. Connect the output of the WiMAX Map File element to the input of the 2800 VSA element. 
5. From the main menu, select File > Save Project As... and then save the project. 

 
 

Verify the Signals on the VSA 
1. Connect the output of the VSG to the input of the VSA. 
2. On the VSA, select Preset > Spectrum > Standards > 802.16x to view the constellation diagram and other 

parameters. 

 

Generating a WiMAX MIMO Signal 

WiMAX MIMO, also known as Wave 2, supports space-time coding (STC) and spatial multiplexing (SM) in WiMAX 
signals. STC uses Alamouti scheme (Matrix A) to provide transmit diversity as shown in Figure 1. Spatial 
multiplexing is also referred to as MIMO and uses Matrix B, as shown in Figure 2. STC/MIMO is often used to 
indicate WiMAX MIMO mode.  
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In WiMAX downlink, both STC and SM are used. In WiMAX uplink, collaborative spatial multiplexing is used. Two 
users, each only has one antenna, can transmit collaboratively in the same slot as if two streams are spatially 
multiplexed from two antennas of the same user.  

 
Figure 1: Space-Time Coding Diagram 
 

 
Figure 2: Spatial Multiplexing 
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Figure 3: Collaborative Spatial Multiplexing for Uplink 
 

In SignalMeister, the MIMO mode offers WiMAX MIMO selection. There are two options: 2x Matrix A (STC) and 2x 
Matrix B (SM) in the downlink. MIMO mode is found in DL Subframe >Zone. 

 
In uplink, MIMO mode is found in the UL Subframe > Zone > Burst. 

 
Generating WiMAX MIMO signals follows the same steps as in Generating a WLAN SISO Signal and Analyzing it 
on a VSA. Here, WiMAX downlink MIMO is used as an example. However, the WiMAX files are not downloaded 
into the Series V2800 VSAs because the VSAs will be used for data collection in MIMO mode and the analysis will 
be done on the PC in SignalMeister. This is different from WiMAX SISO signal analysis which can be done in the 
embedded WiMAX analysis of the Series V2800 VSA. 

Agilent V2895A MIMO Synchronization Unit 
MIMO Application Guide 71 



Section 3: Using SignalMeister™ 

Put Elements into the Projects View and Connect the Elements 
1. In the SignalMeister Toolbox, select the WiMAX folder to display the list of WiMAX elements. 
2. Drag and drop the DL 10 MHz, 1024 FFT 2xMIMO element into the Projects view. 
3. In the Toolbox, select the Files folder to display the list of Files elements. 
4. Drag and drop the 2x ARB File and WiMAX Map File elements into the Projects view. 
5. In the Toolbox, select the Signal Generators folder to display the list of signal generator elements. 
6. Drag and drop the signal generator 2900 Nx MIMO element into the Projects view. 
7. Double-click the element to open the How Many Instruments dialog. 
8. Select the number of instruments in your configuration (in this example it is 2). 
9. Connect the elements as shown below. 

 
 

Run the Project 
1. Configure each element appropriately by double-clicking on the element. 
2. From the main menu, select File > Save Project As... then save the project. 
3. Select Projects > Load All to download the file to the specified location in the VSA, and load it into the ARB 

memory. 
The elements will turn green to show a successful build. 
 

Verify Signals on the VSAs 
1. Place both the Series V2800s and Series V2900s into MIMO mode. 
2. Load the corresponding ARB file into the Series V2900 ARB memory and load it. 
3. Configure the frequency and power level, then turn the RF to On. 
4. On the Series V2900s 

• Set the master to Trigger Now. 
• Set the slave to Trigger Now.  

5. On the Series V2800s 
• Set the Frequency and Reference Level as appropriate. 
• Place both Series V2800s into Zero-Span mode. 
• Set the Sweep Time appropriately. 
• Set the Trigger Source to either Free Run or Video Trigger. If Video Trigger is selected, set the Trigger 

Level as well. 
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By now, waveforms should be displayed on the analyzers. If not, 

1. Connect the output of the VSG to the input of the VSA. 
2. On the VSA, select Preset > Spectrum > Standards > 802.16x to view the constellation diagram and other 

parameters. 
3.  Then load the testing signals again for verification.  

Successfully Triggering WiMAX MIMO Signals 

WiMAX MIMO signals pose an interesting challenge to video triggering. Most OFDM MIMO standards have all of 
the transmitters come on synchronously, so you can choose a specific transmitter and successfully trigger a signal. 

WiMAX, however, only uses MIMO as part of the data region. When the signal first comes on, only the master 
transmitter sends out the header information. Shown below is an example of a 2x2 WiMax MIMO transmission: 

 
Note that the master transmitter (Channel 1) comes on approximately 500 µsec prior to the slave transmitter 
(Channel 2). The problem can be described as such; a MIMO system must choose a single input from which to 
derive the video trigger. By convention, the master receiver is used. If you cable the slave transmitter to the master 
receiver, you get the situation shown below: 
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Channel 1 (the blue trace) is the signal received at the master receiver. The video trigger from the blue trace did not 
occur until 500 µsec after Channel 2 (the white trace) became active (you can only see about 200 µsec in this 
graph).  Since the trigger was so late, the WiMax header was missed, and the signal was not demodulated. 

Knowing that this situation exists, you have to decrease the video trigger delay by 500 µsec, so acquisition begins 
in time to capture both pulses in their entirety, as is shown in the figure below: 

 
In this case, the trigger delay was reduce from 322 µsec to -20 µsec. Determining the required trigger delay can be 
done from the SignalMeister analysis window. If you place SignalMeister in a Continuous sweep, display the IQ 
Amplitude graph, and begin reducing the video trigger delay, you can see when you are capturing enough of the 
signal to successfully demodulate. 

In summary, there are 3 choices to get reliable acquisitions of WiMAX MIMO: 

• Always ensure that the master transmit goes to the master receive 
• Look for the case where the video trigger needs negative delay and add the delay when needed. 
• Use free run trigger, and an acquisition time long enough to always get a complete burst. This is typically twice 

the WiMAX frame time. 

Optimizing WiMAX MIMO Signals 

The SignalMeister optimize function assumes that the master transmitter is cabled to the master receiver. The 
Optimize function will fail in any other configuration, as it attempts to use video triggering. In order to use the 
Optimize function, you must ensure that the master transmitter output is connected to the master MIMO receiver. If 
the device being measured does not have the transmitter outputs labeled, it may take some trial and error to find 
the right connections. 
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WLAN 
The configuration dialog windows for 802.11a/b/g/j all have a similar format. There are a relatively small number of 
parameters required for these standards. The basic parameters are entered on the following screen. These 
parameters either have a valid range of numbers from which to choose or an item to select from a drop down list.  

 
The specific payload data can be entered by selecting Configure PSDU (see the figure above) and entering values 
in the WLAN PSDU Configuration dialog (see figure below). 
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Generating a WLAN SISO Signal 

In this section, a SISO 802.11 a/g signal is generated step by step. Then the Series V2800 VSA embedded WLAN 
option will be used to analyze and verify the generated signal. 

Put Elements into the Projects View 
1. In the SignalMeister Toolbox, select the WLAN folder to display the list of WLAN elements. 
2. Drag and drop a WLAN element (for example, the 802.11a, g 54 Mbps) into the Projects view. 
3. In the Toolbox, select the Files folder to display the list of File elements. 
4. Drag and drop the ARB File element into the Projects view. 
5. In the Toolbox, select the Signal Generators folder to display the list of signal generator elements. 
6. Drag and drop the 2900 VSG element into the Projects view. 
7. The three elements should be configured as shown in the figure below. 

 
Connect the Elements 
1. Use the Connect Elements icon to connect the output of the 802.11a,g 54 Mbps element to the ARB File 

input. 
2. Connect the output of the ARB File element to the input of the 2900 VSG. 
3. Click and drag a rectangle to enclose all three elements.  
4. From the main menu, select Worksheets > Align Horizontal (alternately, you can select the Align Horizontal 

icon from the toolbar). 
Now the elements are connected together and aligned as shown below. 
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Configure the Elements 
1. Double-click each element to configure the parameters of each element. Refer to WLAN signal generation for 

more information. If you need more information regarding each individual parameter refer to the SignalMeister 
Help. Refer to Basic SignalMeister Tasks for information on ARB file and instrument configurations. 

2. From the main menu, select File > Save Project... to save the project. 
 

To run the project 

There are four options to run the project from SignalMeister's Projects menu. 

• Run Conflict Analyzer: Displays any errors or conflicts in the current configuration in the Status area. 
• Build All: Builds an ARB file that contains all of the elements of the project including the elements on multiple 

worksheets. The ARB file is created and stored on your PC. 
• Download All: Downloads the ARB files from your PC to the signal generator memory. 
• Load All: Loads all of the ARB files in the current project to the signal generator that is configured in your 

project. This selection makes the ARB file ready to play in the signal generator. 
 

From the main menu, select Projects > Build All to build the ARB file.  
 

– or – 
 

Select Projects > Load All to download the ARB file to the specified location in the VSA, and load it into the ARB 
memory. 

 

Generating WLAN MIMO Signals 

The input parameters for 802.11n are similar to Generating a WLAN SISO Signal and Analyzing it on a VSA. 
However, there is an additional parameter called the MCS number. The MCS number of an 802.11n signal will 
determine the modulation format, coding scheme, and also the number of MIMO output streams in the waveform 
data. For example, MCS 15 has two output streams. The following figure shows how to generate the 2x2 MIMO 
setup for MCS-15. 

 
In this example, the two ARB file elements would have different file names. The 2x2 MIMO signal source object 
allows the input of communication addresses for both signal sources and configures the MIMO parameters for the 
system. 
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The PSDU configuration for 802.11n also contains additional controls, as shown below. 
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There are two default standard templates in the Toolbox under the Standard Templates folder. Use them as an 
example to customize your own project.  

From the Toolbox, select the Standard Template folder and click and drag the 4xMIMO Complex Impairments 
element to the Projects worksheet. Notice how the element automatically opens itself when it is placed on the 
worksheet. 
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8 x MIMO Signal Generation – IQ Files 
This procedure shows MIMO signal generation capability for eight Series V2800s. There is no specific supported 
standard in SignalMeister to generate 8x MIMO signals. In the case that you would like to develop your own 8x 
MIMO system, user-defined IQ data sources are used as the following example 

Put Elements in Projects View and Connect them 
1. From the Toolbox, open the File folder and drag and drop the IQ Importer element (eight times) onto the 

Projects view. 
2. Open the Signal Analyzers folder and drag and drop 2800 Nx MIMO VSA to the Projects view. 
3. Connect the  IQ Importer elements to the 2800 Nx MIMO VSA elements as shown below. 

 

Configure the Elements and Run the Project 
1. Configure each user-defined data source in the DP IQ Importer appropriately. 
2. The Configuration window of the Series V2800 8X MIMO is similar to other Series V2800 MIMO configurations. 

It supports eight Series V2800s in VISA Resource, MIMO configuration, ARB configuration, and LXI Web 
Interface as shown below. 
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3GPP and 3GPP2 
The 3GPP (WCDMA/HSPA) and 3GPP2 (cdmaOne/cdma2000/EV-DV) waveform parameters include a number of 
general parameters, a list of channels to include, and specific parameters for each channel. This complex data 
structure is displayed in a tree structure. This provides a quick view of the channel configuration and easy 
navigation to the specific channel parameters. Several default templates are provided for these standards, covering 
simple and complicated configurations. In addition, specific parameters (not all parameters) from anywhere in the 
tree can be defined as “Favorites” giving a quick way to change the most common parameters. This feature is 
shown in the following screen shots. 

 

 
Building 3GPP and 3GPP2 signals is the same as building other signals in SignalMeister. Use the following steps to 
build a 3GPP downlink signal as shown. Default parameters will be used in this example. 

1. Put elements in Project View. 
2. Con nect elements. 
3. Config ure elements. 
4. Save and Run the Project. 
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Refer to Generating WiMAX MIMO Signals and Analyzing them on a VSA for similar steps for the procedures 
above. 

 
5. Verify Signals on the VSA and VSG. 
6. After building the ARB file and loading it into the VSG ARB memory, connect the VSG to the VSA.  
7. Use the WCDMA Downlink personality to analyze the signal. 
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Signal Analysis 
SignalMeister supports analyzing WiMAX and WLAN signals in both SISO and MIMO. SISO analysis is similar to 
the corresponding embedded analysis, but it provides more ways of displaying measurement data, reporting more 
measurement results, and offers easier and quicker transporting measurement results to the PC. However, SISO 
analysis in SignalMeister is slower than embedded SISO analysis as it has to go through data collection over 
GPIB/LAN/USB. 

MIMO analysis can only be done in SignalMeister. In this fashion, VSAs are used to collect IQ data, and all analysis 
are done in SignalMeister. No specific license is needed on the VSAs. Unlike the license for signal generation 
residing in signal generator, the licenses for signal analysis are residing in the SignalMeister USB license key. With 
the license key connected, the valid licenses are displayed from the SignalMeister File > Manage Licenses 
window. 

 
 

NOTE:  SignalMeister’s analysis features cannot be operated using remote computer access tools (for example, 
while the Desktop Control Panel is running). 
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WiMAX Analysis 
WiMAX® signal analysis requires use of the Map file that is generated with the ARB file. The Map file is stored on 
the PCs hard drive in the My Documents folder, and can be downloaded into the Agilent Series V2800 VSA using 
the SignalMeister application or a USB device. 

To open a WiMAX Map file, select Use Map File from the Map Information Decoding drop-down menu, then 
either type in the location and file name of the Map file in the Map File Name text box, or click the More button 

  to open a dialog that allows you to navigate to the Map file location. 

 
 

Analyzing a SISO WiMAX Signal in SignalMeister 

This tutorial demonstrates how to use SignalMeister's simulation mode to create a WiMAX® SISO downlink signal, 
add AWGN noise to the signal, and then demodulate the received transmission. The simulated analyzer displays 
both the graphical data and computed parameters. The final steps of the tutorial show you how to increase the 
noise power, then view the degraded signal. 

Hint:  This tutorial can be used for signal types other than WiMAX as the steps in building a project and 
analyzing a waveform are the same for all signal types. Simply follow each of the steps while substituting 
the appropriate elements for the type of waveform analysis you wish to perform. 

 

Part 1 – Build the waveform 
1. Click the WiMAX button on the Toolbox to display the available elements. 
2. Drag and drop the DL 10 MHz, 1024 FFT signal element from the WiMAX tool set onto the Projects worksheet. 
3. Click the Operations button on the Toolbox, then drag and drop the AWGN (Additive White Gaussian Noise) 

element to the right-hand side of the WiMAX signal element. 
4. Click the Signal Analyzers button on the Toolbox, then drag and drop the 1x VSA Simulator element to the 

right-hand side of the AWGN element. 
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5. Re-open the WiMAX tool set, then drag and drop the WiMAX 1x Analysis element to the right-hand side of the 
1x VSA Simulator. 

6. Your project should look like something like this so far: 

 
7. Click the Connect Elements button on the Main toolbar to make it active. 
8. Beginning with the DL 10 MHz, 1024 FFT WiMAX element (far left), click on that element then click the AWGN 

element to connect them. 
9. Click the AWGN element then click the 1x VSA Simulator element to connect them.  
10. Repeat this until all elements are connected and a path exists from the signal element to the analysis function. 
11. Using the mouse (or the touchpad), left-click, hold and drag across all the elements to create a box around the 

project. 

 
12. Click the Align Horizontal icon on the main toolbar to align the elements horizontally. 
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13. Your project should look like this: 

 
14. On the main toolbar, select Project > Build All from the Project menu. If all of the files are built correctly, and 

there are no errors or conflicts, then the WiMAX signal, AWGN and VSA Simulator elements all become green 
in color. The Status window displays a message that no errors or conflicts were found. 

 
15. The WiMAX downlink signal has been created, Gaussian white noise has been added to it, and the VSA 

simulator is set to demodulate, display and compute parameters on the signal. 
 

Part 2 – Analyze the signal 

NOTE: The waveforms in th e too lbox are exa mple waveforms and are starting points for the creation of u ser-
defined waveforms. Numerous parameters are programmable. 

1. Double-click the DL 10 MHz 1024 FFT signal element to open the WiMAX configuration dialog. 
2. Select Common from the tree view to see that the default parameters are: 

• FFT Size: 1024 
• Bandwidth: 10 MHz (the subcarriers are less than 10 kHz apart) 
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3. Select DCD from the tree view to see that the DCD (Downlink Channel Descriptor), that defines channel 
structure details, uses QPSK modulation. 

 
4. Select Burst from the tree view to see that the data is transmitted with 64QAM modulation. 

 
5. Now the WiMAX 1x Analysis element can plot, graph and perform computations on the received signal. This 

tutorial displays the constellation of the signal, the EVM vs. Subcarrier plot, a waveform amplitude plot (power 
vs. time), a table of computed parameters and a single-sweep/continuous-sweep instrument control function. 

6. Dou ble-click the WiMAX 1x Analysis element to open the 802.16e OFDMA WiMAX Analysis window. 
7. Select Displays > Graphs, then click Constellation. Repeat this to also add the EVM vs. Subcarrier and 

Waveform Amplitude graphs. The EVM vs. Subcarrier graph shows the EVM for each carrier and the 
Waveform Amplitude graph shows the power vs. time plot of the 500 µs transmission burst. 
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8. Select Displays > 802.16e Parameters Table to display Relative Constellation Error (RCE) parameters, 
channel power and other computations. 

 
9. Note that the 802.16e Parameters Table shows the number of sweeps and the minimum, maximum and 

average values for each of the parameters. 
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10. Select Settings > Instrument Control to display the control window for the WiMAX Analysis that allows you to 
select either a Single Sweep or Continuous Sweep. 
 

11. Select View > Tile Vertically to see a display of all the open windows. 
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12. Select View > Minimize to return to the SignalMeister project window.  
13. Double-click on the AWGN element, then raise the noise Power to -20 dBc and click OK. 

 
14. Return to the Instrument Control window and click Single Sweep. Note that the Constellation is less precise, 

the EVM vs. Subcarrier is higher (not as good), and the RCE is higher. 

 

 

 

Part 3 – Optional steps for a more dynamic display 

Additive White Gaussian Noise (AWGN) can be added to the VSA simulator to display more realistic data even if 
the AWGN element is not used. The noise in the VSA simulator is randomized so that it changes with each sweep, 
so using the VSA's internal noise source creates a changing and more realistic display. 

1. Minimize the Analysis window and return to the Projects window.  
2. Remove the AWGN element from your project, and remove one of the connectors. 
3. Connect the DL 10 MHz, 1024 FFT signal element to the 1x VSA Simulator element. 
4. Double-click on the 1x VSA Simulator.  
5. Select the Add Noise check-box and increase the power to -20 dBc, then click OK. 
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6. Return to the Analysis window and click Continuous Sweep from the Instrument Control panel. Note the 

changing displays. The update rate is a function of your PC speed.  
7. Now check the 802.16e Parameters table, the Constellation and EVM vs. Subcarrier graphs to view the 

changes due to the addition of noise at the 1x VSA Simulator element. 
 

Analyzing MIMO WiMAX Signals in SignalMeister 

 
WiMAX MIMO Analysis Simulation 

 

 
WiMAX MIMO Analysis using an Instrument 
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WLAN Analysis Using SignalMeister 
 

Analyzing a SISO Signal in SignalMeister 

Following the example in Generating a WLAN SISO Signal and Analyzing it on a VSA, now SignalMeister is used to 
analyze the same signals. 

There are two ways to do this: 

• Use the SignalMeister built-in Series V2800 simulator 
• Use the Series V2800 VSA hardware with SignalMeister 

The first method does not involve any hardware. It can be used for demonstration purposes and to verify the signal 
generated from SignalMeister in the baseband (IQ) level. A signal generation element is used as the starting point, 
which is the same as generating an ARB file. Instead of putting an ARB file element at the output of the signal 
generation element, a VSA simulator element is connected instead.  
 

Using the Simulation Method 

Put Elements in Projects View and Connect Them Together  
1. From the Toolbox, select the WLAN folder and drag and drop the 802.11 a, g 54 Mbps on to the Projects view. 
2. From the Toolbox, select the Signal Analyzer folder and drag and drop the 1x VSA Simulator element on to 

the Projects view. 
3. From the Toolbox, select the WLAN folder and drag and drop the 802.11 agj element on to the Projects view. 
4. Connect the elements together. 

 
 

Configure the Elements, Save and Run the Project 
1. Configure 802.11 a, g 54 Mbps for the signal you want to analyze.  
2. Double click 802.11 agj Analysis. The 802.11 agj SISO analysis window is displayed. 

The startup window will be empty if it has never been configured before. The menu bar has four menus: File, 
View, Displays, and Settings. 
• The File menu is used to exit the Analysis window. 
• The View menu is used to globally maintain the Settings and Displays. You can open all of the windows 

from Settings and Displays and then rearrange them automatically. 
• The Settings Menu supports instrument control, IQ capture settings, specific settings for the type of to-be-

analyzed signal, in this case, WLAN settings.  
• The Displays Menu supports various graphs, charts and a parameters reporting table. 
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The following figure shows how an analysis window may look like after opening and customizing sub-windows. 

 
3. Go back to the main SignalMeister window and select Projects > Build All to generate fresh data for analysis. 

 

Using the Hardware Method 

The second method uses instruments to do the SISO analysis. This is a little different from simulation mode. Here, 
it is assumed that a 802.11 a/g signal is fed into a Series V2800 VSA. In our case, such a signal is generated in the 
previous session of Generating a WLAN SISO Signal and Analyzing it on a VSA. It is output from the Series V2900 
VSG and directly fed into the Series V2900 VSG. From here, there are only two elements needed as shown below.  

 
Similar to the first example (the Simulation method), you need to configure instrument control and WLAN settings 
(such as sweep time and type of trigger source). What is different from the simulation method is that the control 
buttons in the Instrument Control sub-window are activated. The Initialize button allows initialization of the VSA as 
specified by the settings in this window. Single Sweep or Continuous Sweep offer two types of sweeping for your 
convenience. The Optimize button offers automatic optimization based on the existing settings. 
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Analyze MIMO WLAN Signals in SignalMeister 

Analyzing a MIMO 802.11n signal is similar to SISO analysis. Both simulation and non-simulation modes are 
available. 

The following figures show a project that simulates 2x 802.11n MIMO analysis. Refer to Analyzing a SISO Signal in 
SignalMeister for the steps to build and run the project. 
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